[gs-devel] [gs-cjk 02132] "Resource" directory: why version specific?

Mike FABIAN mfabian at suse.de
Tue Mar 8 02:51:34 PST 2005


Ghostscript 8.15 comes with a "Resource" directory which is located at

    /usr/share/ghostscript/8.15/Resource/

Does this have to be a version specific subdirectory?
Wouldn't it be better to have it one level higher, i.e. here:

    /usr/share/ghostscript/Resource

Or is there really stuff in that directory which depends on the
Ghostscript version?

Ghostscript expects CID-keyed fonts in a subdirectory
"Resource/CIDFont". If the "Resource" directory is already at a
version dependent location, rpm packages containing CID-keyed fonts
will end up depending on a specific version of Ghostscript, which
appears to be unnecessary.

The "Resource" directory in Ghostscript 8.15 already comes with
3 subdirectories:

    Resource/CMap         
    Resource/ColorSpace
    Resource/Decoding

The character maps in the "CMap" subdirectory certainly do
not depend on the Ghostscript version.

What about "ColorSpace" and "Decoding"? I don't know what these
directories are used for. Do they depend on the version of
Ghostscript?

-- 
Mike FABIAN   <mfabian at suse.de>   http://www.suse.de/~mfabian
睡眠不足はいい仕事の敵だ。




More information about the gs-devel mailing list