[gs-devel] Re: [gs-cvs] rev 8392 - trunk/gs/src

SaGS sags5495 at hotmail.com
Wed Nov 21 02:17:22 PST 2007


Hi,

I don't have access to the Win95 system right now, but on another
one with VS6 on WinXP-SP2 I get the following. In all cases, there
is a "DEVSTUDIO=C:\Program Files\VC++" in the make command-line,
debug build done from the IDE.

(A) Revision 8395 as-is, without setting %MSVCDir%:

    ...
     "%MSVCDir%\bin\cl"  ...etc... .\src\genarch.c /link
    The system cannot find the path specified.
    NMAKE : fatal error U1077: '"%MSVCDir%\bin\cl"' : return code '0x1'
    Stop.
    Error executing nmake.

(B) Revision 8395 as-is, with %MSVCDir% set:

    Same error as for (A). I have added a "set" command to the makefile, 
    and I can see the "MSVCDir=C:\Program Files\VC++" defined, isn't 
    just not expanded. I also tried "MSVCDIR" (all caps); the case is 
    preserved in the environment, but the result is the same: no 
    expansion.

(C) Reverting to "COMPBASE=$(DEVSTUDIO)\VC98":

    It passes. But, of course, the linker receives no "/LIBPATH"...

sags
(sorry if the message appears duplicated, the 1st time I used 
a wrong e-mail address and I think it didn't pass)

----- Original Message ----- 
From: "Ralph Giles" <giles at ghostscript.com>
To: "SaGS" <sags5495 at hotmail.com>
Cc: "gs-devel" <gs-devel at ghostscript.com>
Sent: Wednesday, 21 November 2007 08:34
Subject: Re: [gs-devel] Re: [gs-cvs] rev 8392 - trunk/gs/src


> Ah, big build patches just before release! :)
>
> Ray just committed something in a similar vein. Can you check if that
> works for you with or without reverting r8392?
>
> -r
> _______________________________________________
> gs-devel mailing list
> gs-devel at ghostscript.com
> http://www.ghostscript.com/mailman/listinfo/gs-devel
>



More information about the gs-devel mailing list