[gs-devel] Ubuntu Gutsy does not print secured PDFs via Acroread and Ghostscript

Ken Sharp ken.sharp at artifex.com
Tue Nov 27 04:53:44 PST 2007


At 12:34 27/11/2007 +0000, Till Kamppeter wrote:


>Do not know the exact security level, but some reports have example files 
>linked or attached:

Thanks Till. Looks like its simple 40-bit RSA encryption. Which means it 
can't be any of the PDF 1.5 or 1.6 fixes. Unfortunatley, it also doesn't 
fit the description of the other fix, which related to an invalid Length 
entry when V=1. This file has a correct Length entry...

I'm going to revert one of my GS installations back to 8187, and check to 
see if I can reproduce the problem.


                     Ken

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
TASK: Shoot yourself in the foot.
BASIC: Shoot yourself in the foot with a water pistol. On large systems, 
continue until entire lower body is waterlogged.
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -



More information about the gs-devel mailing list