[gs-devel] Ubuntu Gutsy does not print secured PDFs via Acroread and Ghostscript

Marcos Woehrmann marcos.woehrmann at artifex.com
Tue Nov 27 12:54:53 PST 2007


> the following bug was reported about Ubuntu Gutsy:
>
> https://bugs.launchpad.net/ubuntu/+source/ghostscript/+bug/172264
>
> acroread 8.1.1 is not able to print secured PDFs on non-PostScript
> printers. Ghostscript crashes in such cases. This does not happen any
> more and all works fine when upgrading to the final Ghostscript 8.61.

Till,

I've been working on this issue but still see the problem with the
final Ghostscript 8.61 as well as the current gshead.

Did you verify that it only happens with the pre-release version in
Ubuntu 7.10 or was this reported by a user?  Replacing /usr/bin/gs
with a ghostscript that's not a just a stub that calls
/usr/lib/libgs.so.8 fixes the problem, even if the bin/gs is built
from r8187.  This confused me for a while, so that might explain why
someone reported that it works with the released Ghostscript 8.61.

To make it easier for us to work on the problem I've generated a test
case which does not involve acrobat or cups and added a bug to our bug
tracker: http://bugs.ghostscript.com/show_bug.cgi?id=689577

marcos

-- 
Marcos H. Woehrmann   marcos.woehrmann at artifex.com


More information about the gs-devel mailing list