[gs-devel] Ghostscript 9.07 and GhostPDL 9.07

Chris Liddell chris.liddell at artifex.com
Fri Feb 15 10:33:19 UTC 2013


On Fri, 15 Feb 2013 10:18:45 +0000
Tim Waugh <twaugh at redhat.com> wrote:

> Can Ghostscript 9.07 be built against released versions of lcms2, or
> does it require the bundled lcms2?
> 
> When I try to build against lcms2 2.4 I get a link error:
> ./sobin/libgs.so: undefined reference to `cmsPluginTHR'

<sigh> It looks like it needs the patched version.

There was a fairly serious bug in the LCMS2 plugin API that meant there
was no way to attach a pointer to "user data" to the plugin context.

I'll need to talk to the engineer that found and addressed the problem
to find out the status of things with the canonical LCMS2 distribution.
I'll update when I've done that.

Chris



More information about the gs-devel mailing list